#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!^id|id{1,})(?<=id|^).+?(?=id|$)"
Local $sString = "id213123213id12321321id" & @CRLF & _
"id123421321id12312321id65464" & @CRLF & _
"thereisandidanditsnameisbingoidbingoidbingoid2312321" & @CRLF & _
"ghjjhghjgd" & @CRLF & _
"dsadsadasdsaididididididdsadsadsa" & @CRLF & _
"dsa" & @CRLF & _
"das id dsadassa id sdadasdsa " & @CRLF & _
"idsa2311321id2312312id21321312" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")