import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^id|id{1,})(?<=id|^).+?(?=id|$)";
final String string = "id213123213id12321321id\n"
+ "id123421321id12312321id65464\n"
+ "thereisandidanditsnameisbingoidbingoidbingoid2312321\n"
+ "ghjjhghjgd\n"
+ "dsadsadasdsaididididididdsadsadsa\n"
+ "dsa\n"
+ "das id dsadassa id sdadasdsa \n"
+ "idsa2311321id2312312id21321312\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}