use strict;
my $str = 'id213123213id12321321id
id123421321id12312321id65464
thereisandidanditsnameisbingoidbingoidbingoid2312321
ghjjhghjgd
dsadsadasdsaididididididdsadsadsa
dsa
das id dsadassa id sdadasdsa
idsa2311321id2312312id21321312
';
my $regex = qr/(?!^id|id{1,})(?<=id|^).+?(?=id|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}