using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^id|id{1,})(?<=id|^).+?(?=id|$)";
string input = @"id213123213id12321321id
id123421321id12312321id65464
thereisandidanditsnameisbingoidbingoidbingoid2312321
ghjjhghjgd
dsadsadasdsaididididididdsadsadsa
dsa
das id dsadassa id sdadasdsa
idsa2311321id2312312id21321312
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}