import re
regex = re.compile(r"(?!^id|id{1,})(?<=id|^).+?(?=id|$)", flags=re.MULTILINE)
test_str = ("id213123213id12321321id\n"
"id123421321id12312321id65464\n"
"thereisandidanditsnameisbingoidbingoidbingoid2312321\n"
"ghjjhghjgd\n"
"dsadsadasdsaididididididdsadsadsa\n"
"dsa\n"
"das id dsadassa id sdadasdsa \n"
"idsa2311321id2312312id21321312\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")