using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m-s)^(..).*+(?>\r?\n\1.*){2}\K(?:\r?\n\1.*)+";
string substitution = @"";
string input = @"at58
at59
at60
at61
at62
au344
au347
au348
au349
au350
ba5
ba6
ba7
be72
be73
be74
be75
be76 ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}