import re
regex = re.compile(r"(?m-s)^(..).*+(?>\r?\n\1.*){2}\K(?:\r?\n\1.*)+")
test_str = ("at58\n"
"at59\n"
"at60\n"
"at61\n"
"at62\n"
"au344\n"
"au347\n"
"au348\n"
"au349\n"
"au350\n"
"ba5\n"
"ba6\n"
"ba7\n"
"be72\n"
"be73\n"
"be74\n"
"be75\n"
"be76 ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)