import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m-s)^(..).*+(?>\\r?\\n\\1.*){2}\\K(?:\\r?\\n\\1.*)+";
final String string = "at58\n"
+ "at59\n"
+ "at60\n"
+ "at61\n"
+ "at62\n"
+ "au344\n"
+ "au347\n"
+ "au348\n"
+ "au349\n"
+ "au350\n"
+ "ba5\n"
+ "ba6\n"
+ "ba7\n"
+ "be72\n"
+ "be73\n"
+ "be74\n"
+ "be75\n"
+ "be76 ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}