#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/vk\.com\/(?!album-?\d)[^\/\s]*$"
Local $sString = "https://vk.com/album9" & @CRLF & _
"https://vk.com/album123_456" & @CRLF & _
"https://vk.com/a-tut_chot@@#$%$&-ugodno dazhe probely" & @CRLF & _
"https://vk.com/a-tut_chto-to" & @CRLF & _
"" & @CRLF & _
"Если пробелы запрещены, замените [^\/]* на [^\/\s]*" & @CRLF & _
"" & @CRLF & _
"^https:\/\/vk\.com\/(?!album\d)[^\/\s]*$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")