import Foundation
let pattern = #"^https:\/\/vk\.com\/(?!album-?\d)[^\/\s]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
https://vk.com/album9
https://vk.com/album123_456
https://vk.com/a-tut_chot@@#$%$&-ugodno dazhe probely
https://vk.com/a-tut_chto-to
Если пробелы запрещены, замените [^\/]* на [^\/\s]*
^https:\/\/vk\.com\/(?!album\d)[^\/\s]*$
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)