import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/vk\\.com\\/(?!album-?\\d)[^\\/\\s]*$";
final String string = "https://vk.com/album9\n"
+ "https://vk.com/album123_456\n"
+ "https://vk.com/a-tut_chot@@#$%$&-ugodno dazhe probely\n"
+ "https://vk.com/a-tut_chto-to\n\n"
+ "Если пробелы запрещены, замените [^\\/]* на [^\\/\\s]*\n\n"
+ "^https:\\/\\/vk\\.com\\/(?!album\\d)[^\\/\\s]*$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}