$re = '/^https:\/\/vk\.com\/(?!album-?\d)[^\/\s]*$/m';
$str = 'https://vk.com/album9
https://vk.com/album123_456
https://vk.com/a-tut_chot@@#$%$&-ugodno dazhe probely
https://vk.com/a-tut_chto-to
Если пробелы запрещены, замените [^\\/]* на [^\\/\\s]*
^https:\\/\\/vk\\.com\\/(?!album\\d)[^\\/\\s]*$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);