use strict;
my $str = 'https://vk.com/album9
https://vk.com/album123_456
https://vk.com/a-tut_chot@@#$%$&-ugodno dazhe probely
https://vk.com/a-tut_chto-to
Если пробелы запрещены, замените [^\\/]* на [^\\/\\s]*
^https:\\/\\/vk\\.com\\/(?!album\\d)[^\\/\\s]*$';
my $regex = qr/^https:\/\/vk\.com\/(?!album-?\d)[^\/\s]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}