re = /^https:\/\/vk\.com\/(?!album-?\d)[^\/\s]*$/m
str = 'https://vk.com/album9
https://vk.com/album123_456
https://vk.com/a-tut_chot@@#$%$&-ugodno dazhe probely
https://vk.com/a-tut_chto-to
Если пробелы запрещены, замените [^\\/]* на [^\\/\\s]*
^https:\\/\\/vk\\.com\\/(?!album\\d)[^\\/\\s]*$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end