using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(\b(?:AND|OR|NOT)\b|[()])\s*";
string input = @"Frank and Bob are nice AND NOT (Henry is good OR Sam is 102 years old)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}