re = /\s*(\b(?:AND|OR|NOT)\b|[()])\s*/m
str = 'Frank and Bob are nice AND NOT (Henry is good OR Sam is 102 years old)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end