package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(\b(?:AND|OR|NOT)\b|[()])\s*`)
var str = `Frank and Bob are nice AND NOT (Henry is good OR Sam is 102 years old)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}