$re = '/\s*(\b(?:AND|OR|NOT)\b|[()])\s*/m';
$str = 'Frank and Bob are nice AND NOT (Henry is good OR Sam is 102 years old)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);