// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*(\b(?:AND|OR|NOT)\b|[()])\s*").unwrap();
let string = "Frank and Bob are nice AND NOT (Henry is good OR Sam is 102 years old)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}