import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\/\\/(?:([^\\/]+?)\\.)?(([^\\/]+)\\.([A-Z]{2,}))";
final String string = "https://forum.keyboardmaestro.com/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727\n\n"
+ "https://controldesign.com/industrynews/2020/pepperl-fuchs-announces-first-online-summit/\n\n"
+ "https://controldesign.co.uk/industrynews/2020/pepperl-fuchs-announces-first-online-summit/\n\n"
+ "https://forum.keyboardmaestro.com.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727\n\n"
+ "https://forum.keyboardmaestro.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727\n\n"
+ "https://someCompany.us\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}