import re
regex = re.compile(r"(?i)\/\/(?:([^\/]+?)\.)?(([^\/]+)\.([A-Z]{2,}))", flags=re.UNICODE)
test_str = ("https://forum.keyboardmaestro.com/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727\n\n"
"https://controldesign.com/industrynews/2020/pepperl-fuchs-announces-first-online-summit/\n\n"
"https://controldesign.co.uk/industrynews/2020/pepperl-fuchs-announces-first-online-summit/\n\n"
"https://forum.keyboardmaestro.com.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727\n\n"
"https://forum.keyboardmaestro.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727\n\n"
"https://someCompany.us\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")