re = /(?i)\/\/(?:([^\/]+?)\.)?(([^\/]+)\.([A-Z]{2,}))/
str = 'https://forum.keyboardmaestro.com/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://controldesign.com/industrynews/2020/pepperl-fuchs-announces-first-online-summit/
https://controldesign.co.uk/industrynews/2020/pepperl-fuchs-announces-first-online-summit/
https://forum.keyboardmaestro.com.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://forum.keyboardmaestro.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://someCompany.us
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end