// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(?i)\/\/(?:([^\/]+?)\.)?(([^\/]+)\.([A-Z]{2,}))").unwrap();
let string = "https://forum.keyboardmaestro.com/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://controldesign.com/industrynews/2020/pepperl-fuchs-announces-first-online-summit/
https://controldesign.co.uk/industrynews/2020/pepperl-fuchs-announces-first-online-summit/
https://forum.keyboardmaestro.com.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://forum.keyboardmaestro.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://someCompany.us
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}