const regex = /(?i)\/\/(?:([^\/]+?)\.)?(([^\/]+)\.([A-Z]{2,}))/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\\/\\\/(?:([^\\\/]+?)\\.)?(([^\\\/]+)\\.([A-Z]{2,}))', 'gu')
const str = `https://forum.keyboardmaestro.com/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://controldesign.com/industrynews/2020/pepperl-fuchs-announces-first-online-summit/
https://controldesign.co.uk/industrynews/2020/pepperl-fuchs-announces-first-online-summit/
https://forum.keyboardmaestro.com.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://forum.keyboardmaestro.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://someCompany.us
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}