$re = '/(?i)\/\/(?:([^\/]+?)\.)?(([^\/]+)\.([A-Z]{2,}))/u';
$str = 'https://forum.keyboardmaestro.com/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://controldesign.com/industrynews/2020/pepperl-fuchs-announces-first-online-summit/
https://controldesign.co.uk/industrynews/2020/pepperl-fuchs-announces-first-online-summit/
https://forum.keyboardmaestro.com.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://forum.keyboardmaestro.de/t/how-can-i-get-only-the-domain-name-from-the-frontend-browser/18727
https://someCompany.us
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);