import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ ]*([+-]?[ ]*(([1-9][0-9]*)[ ]*(\\\\*[ ]*x[ ]*(\\\\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\\\\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*)";
final String string = "判断多项式是不是合法\n"
+ "题目文档:\n"
+ "https://images.ptausercontent.com/2746fa4c-db55-4a55-beb9-459cea89b99d.pdf\n\n"
+ "1-2*x^-2+5*x^12-4*x+12\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}