$re = '/[ ]*([+-]?[ ]*(([1-9][0-9]*)[ ]*(\\\\*[ ]*x[ ]*(\\\\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\\\\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*)/m';
$str = '判断多项式是不是合法
题目文档:
https://images.ptausercontent.com/2746fa4c-db55-4a55-beb9-459cea89b99d.pdf
1-2*x^-2+5*x^12-4*x+12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);