# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[ ]*([+-]?[ ]*(([1-9][0-9]*)[ ]*(\\*[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*)"
test_str = ("判断多项式是不是合法\n"
"题目文档:\n"
"https://images.ptausercontent.com/2746fa4c-db55-4a55-beb9-459cea89b99d.pdf\n\n"
"1-2*x^-2+5*x^12-4*x+12\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.