// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[ ]*([+-]?[ ]*(([1-9][0-9]*)[ ]*(\\*[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*)").unwrap();
let string = "判断多项式是不是合法
题目文档:
https://images.ptausercontent.com/2746fa4c-db55-4a55-beb9-459cea89b99d.pdf
1-2*x^-2+5*x^12-4*x+12
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}