import Foundation
let pattern = #"[ ]*([+-]?[ ]*(([1-9][0-9]*)[ ]*(\\*[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
判断多项式是不是合法
题目文档:
https://images.ptausercontent.com/2746fa4c-db55-4a55-beb9-459cea89b99d.pdf
1-2*x^-2+5*x^12-4*x+12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)