# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?![\/#$]|\.(?!\s))\p{P}//gm;t' <<< ".net, asp.net hello. world, c#"