re = /(?![\/#$]|\.(?!\s))\p{P}/m
str = '.net, asp.net hello. world, c#'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result