const regex = new RegExp('(?![/#$]|\\.(?!\\s))\\p{P}', 'gm')
const str = `.net, asp.net hello. world, c#`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);