using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![/#$]|\.(?!\s))\p{P}";
string substitution = @"";
string input = @".net, asp.net hello. world, c#";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}