$re = '~(?![/#$]|\.(?!\s))\p{P}~m';
$str = '.net, asp.net hello. world, c#';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;