#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)__([a-zA-Z_]+)__\s*=\s*(?:\"|')((?<=\").+(?=\")|(?<=').+(?='))"
Local $sString = "__name__ = "nc_local_sandbox"" & @CRLF & _
"__version__ = '0.4.3'" & @CRLF & _
"__description__ = "A Sandbox manager for the Nimble Collective platform API"" & @CRLF & _
"__author__ = "Nimble Collective"" & @CRLF & _
"__authoremail__ = "tmosley@nimblecollective.com"" & @CRLF & _
"__multi_word__ = "some string here"" & @CRLF & _
"__multiquotes__ = "some string that has 'inner' quotes"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")