# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"__([a-zA-Z_]+)__\s*=\s*(?:\"|')((?<=\").+(?=\")|(?<=').+(?='))"
test_str = ("__name__ = \"nc_local_sandbox\"\n"
"__version__ = '0.4.3'\n"
"__description__ = \"A Sandbox manager for the Nimble Collective platform API\"\n"
"__author__ = \"Nimble Collective\"\n"
"__authoremail__ = \"tmosley@nimblecollective.com\"\n"
"__multi_word__ = \"some string here\"\n"
"__multiquotes__ = \"some string that has 'inner' quotes\"\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.