using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__([a-zA-Z_]+)__\s*=\s*(?:\""|')((?<=\"").+(?=\"")|(?<=').+(?='))";
string input = @"__name__ = ""nc_local_sandbox""
__version__ = '0.4.3'
__description__ = ""A Sandbox manager for the Nimble Collective platform API""
__author__ = ""Nimble Collective""
__authoremail__ = ""tmosley@nimblecollective.com""
__multi_word__ = ""some string here""
__multiquotes__ = ""some string that has 'inner' quotes""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}