import Foundation
let pattern = #"__([a-zA-Z_]+)__\s*=\s*(?:\"|')((?<=\").+(?=\")|(?<=').+(?='))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
__name__ = "nc_local_sandbox"
__version__ = '0.4.3'
__description__ = "A Sandbox manager for the Nimble Collective platform API"
__author__ = "Nimble Collective"
__authoremail__ = "tmosley@nimblecollective.com"
__multi_word__ = "some string here"
__multiquotes__ = "some string that has 'inner' quotes"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)