use strict;
my $str = '__name__ = "nc_local_sandbox"
__version__ = \'0.4.3\'
__description__ = "A Sandbox manager for the Nimble Collective platform API"
__author__ = "Nimble Collective"
__authoremail__ = "tmosley@nimblecollective.com"
__multi_word__ = "some string here"
__multiquotes__ = "some string that has \'inner\' quotes"
';
my $regex = qr/__([a-zA-Z_]+)__\s*=\s*(?:\"|')((?<=\").+(?=\")|(?<=').+(?='))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}