$re = '/__([a-zA-Z_]+)__\s*=\s*(?:\"|\')((?<=\").+(?=\")|(?<=\').+(?=\'))/m';
$str = '__name__ = "nc_local_sandbox"
__version__ = \'0.4.3\'
__description__ = "A Sandbox manager for the Nimble Collective platform API"
__author__ = "Nimble Collective"
__authoremail__ = "tmosley@nimblecollective.com"
__multi_word__ = "some string here"
__multiquotes__ = "some string that has \'inner\' quotes"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);