using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\b[A-Za-z]{2}\d{2}(?!\d)\w*";
string substitution = @"";
string input = @"it is ZZ10ASDJN123 and ZZ100DD22";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}