const regex = /\s*\b[A-Za-z]{2}\d{2}(?!\d)\w*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\b[A-Za-z]{2}\\d{2}(?!\\d)\\w*', 'gm')
const str = `it is ZZ10ASDJN123 and ZZ100DD22`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);