import Foundation
let pattern = #"\s*\b[A-Za-z]{2}\d{2}(?!\d)\w*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"it is ZZ10ASDJN123 and ZZ100DD22"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)