use strict;
my $str = 'it is ZZ10ASDJN123 and ZZ100DD22';
my $regex = qr/\s*\b[A-Za-z]{2}\d{2}(?!\d)\w*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";