$re = '/\s*\b[A-Za-z]{2}\d{2}(?!\d)\w*/m';
$str = 'it is ZZ10ASDJN123 and ZZ100DD22';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;