# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,?\s*\"(\\.|[^\"])+\"\s*:\s*null//gm;t' <<< "{\"a\": null}
{\"a\": 123, \"b\": null}
{\"a\": 123, \"b\": null, \"c\": \"foo\"}
{\"a\": 123, \"b\": null, \"c\": \"foo\", \"blby\\"nazov\": false}
{\"a\": 123, \"b\": null, \"c\": \"foo\", \"blby\\"nazov\\"null hodnotou\": null, \"d\": 1}
{\"a\": 123, \"b\": null, \"c\": \"foo{\\"x\\": null}\", \"d\": 1}
"