import Foundation
let pattern = #",?\s*\"(\\.|[^\"])+\"\s*:\s*null"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{"a": null}
{"a": 123, "b": null}
{"a": 123, "b": null, "c": "foo"}
{"a": 123, "b": null, "c": "foo", "blby\"nazov": false}
{"a": 123, "b": null, "c": "foo", "blby\"nazov\"null hodnotou": null, "d": 1}
{"a": 123, "b": null, "c": "foo{\"x\": null}", "d": 1}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)