use strict;
my $str = '{"a": null}
{"a": 123, "b": null}
{"a": 123, "b": null, "c": "foo"}
{"a": 123, "b": null, "c": "foo", "blby\\"nazov": false}
{"a": 123, "b": null, "c": "foo", "blby\\"nazov\\"null hodnotou": null, "d": 1}
{"a": 123, "b": null, "c": "foo{\\"x\\": null}", "d": 1}
';
my $regex = qr~,?\s*\"(\\.|[^\"])+\"\s*:\s*null~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";