#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m),?\s*\"(\\.|[^\"])+\"\s*:\s*null"
Local $sString = "{"a": null}" & @CRLF & _
"{"a": 123, "b": null}" & @CRLF & _
"{"a": 123, "b": null, "c": "foo"}" & @CRLF & _
"{"a": 123, "b": null, "c": "foo", "blby\"nazov": false}" & @CRLF & _
"{"a": 123, "b": null, "c": "foo", "blby\"nazov\"null hodnotou": null, "d": 1}" & @CRLF & _
"{"a": 123, "b": null, "c": "foo{\"x\": null}", "d": 1}" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)